Compiling openMSX for Armbian 5.59 xenial

Страница 1/6
| 2 | 3 | 4 | 5 | 6

By Shinobi

Master (198)

Аватар пользователя Shinobi

20-10-2021, 18:25

Hi
I tried to compile openmsx..after diwnloading all libraries and running ./configure
I get this
https://ibb.co/MV51ZsX

Although that i downloaded these missing libs and when i try to download them..linux says it is aleeady the newest version

So what to do now??

Для того, чтобы оставить комментарий, необходимо регистрация или !login

By Manuel

Ascended (18237)

Аватар пользователя Manuel

20-10-2021, 19:15

try first: apt-get build-dep openmsx

By Manuel

Ascended (18237)

Аватар пользователя Manuel

20-10-2021, 19:16

You're probably not installing the proper packages. Please let us know which you tried to install exactly.

By Shinobi

Master (198)

Аватар пользователя Shinobi

20-10-2021, 19:33

Apt-get build-dep
Tells me to update sources list...but I didnt know what repository to.put in this file..

By Shinobi

Master (198)

Аватар пользователя Shinobi

20-10-2021, 20:36

I am trying to install the libs that are required by ./configure but they are already installed..
Look
https://ibb.co/F43ynn7

By Shinobi

Master (198)

Аватар пользователя Shinobi

20-10-2021, 20:36

Sources.list..
I removed comments from deb src lines as said by searcging google

By Shinobi

Master (198)

Аватар пользователя Shinobi

20-10-2021, 21:37

After tinkering around..i only have sdl2_ttf missing altgough i find it as you will see in pic below..
And emulation core is marked as NO when calking ./configure
Look
https://ibb.co/QFSXFkP

By Shinobi

Master (198)

Аватар пользователя Shinobi

20-10-2021, 21:45

Sdl2_ttf is not found although it is installed...also why emulation core is marked as NO
Look
https://ibb.co/sqrxkrm

By Manuel

Ascended (18237)

Аватар пользователя Manuel

20-10-2021, 22:53

It says "no", because SDL2_ttf is a required dependency.

Anyway, good question on why it isn't found. Looks like you are hitting this issue: https://github.com/openMSX/openMSX/issues/1281
Short version of the solution: also install the libfreetype6-dev package and retry.

By Shinobi

Master (198)

Аватар пользователя Shinobi

20-10-2021, 23:49

Thank you Manuel..
I now have all the dependecies..i set up the environment variable and compiler to gcc8.. when using (sudo make) i get:
Fatal error..string_view no such file or directory

Look
https://ibb.co/bgVNfpK

By Shinobi

Master (198)

Аватар пользователя Shinobi

21-10-2021, 00:01

[I cant understand why it is not finding string_view while it can find cstring..they are both in /usr/include/c++/8/
cstring is found with no problem..but string_view not found..
Am I missing something??

Страница 1/6
| 2 | 3 | 4 | 5 | 6